Elevated Error Rates

Incident Report for NCSI SafeApp

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 16:30 EDT

Monitoring

Our third-party provider is continuing to work to mitigate any further issues. We will continue to monitor.
Posted Jun 22, 2026 - 11:42 EDT

Identified

We have identified an issue with an application firewall provider which may result in elevated error rates. We have put measures in place to mitigate the impact. We will continue to monitor and provide updates.
Posted Jun 22, 2026 - 10:34 EDT
This incident affected: Website and API.